EN
БЭМ. Блок, Элемент, МодификаторИнструментыСборкаbem-toolsУстановка

Установка bem-tools

Установка

Вам потребуется NodeJS 0.8+ или выше, и npm 1.2.14 или выше. После этого достаточно выполнить команду npm -g install bem.

  • Установить NodeJS:

     https://github.com/joyent/node/wiki/Installation
    
  • Установить npm:

     curl https://npmjs.org/install.sh | sudo sh
    
  • После установки сконфигурируйте NODE_PATH:

     echo 'export NODE_PATH="'$(npm root -g)'"'>> ~/.bashrc && . ~/.bashrc
    

    или

     echo 'export NODE_PATH="'$(npm root -g)'"'>> ~/.zshrc && . ~/.zshrc
    
  • Установить bem-tools:

     npm install bem
    
  • Для установки самой последней версии bem-tools воспользуйтесь командой:

     npm install bem@unstable
    

Использование

Всю информацию о параметрах использования можно получить с помощью bem --help. Для информации о конкретной команде и подкомманде: bem COMMAND --help и bem COMMAND SUBCOMMAND --help.

Shell completion

bash

Если вы используете bash и у вас установлен пакет bash-completion, выполните следующую команду и перелогиньтесь:

bem completion > /path/to/etc/bash_completion.d/bem

Если вы не используете bash-completion, добавьте вывод bem completion себе в .bashrc, а затем перезагрузить:

bem completion >> ~/.bashrc
source ~/.bashrc

zsh

Если вы используете zsh, добавьте вывод bem completion себе в .zshrc и перезагрузить его:

bem completion >> ~/.zshrc
source ~/.zshrc
Если вы заметили ошибку или хотите чем-то дополнить статью, вы всегда можете написать нам об этом.